請選擇 進入手機版 | 繼續訪問電腦版

施勢帆老師的教學網站

 找回密碼
 註冊
搜索
熱搜: 活动 交友 discuz
12
返回列表 發新帖
樓主: shie

CCNA 作業四 RIP & EIGRP 動態路由

[複製鏈接]
1061B108103224 發表於 昨天 01:48 | 顯示全部樓層
本帖最後由 1061B108103224 於 2021-6-22 01:52 編輯

RIP & EIGRP 動態路由
一、靜態路由與動態路由差別
     靜態路由:這種路由由網路管理員手動輸入路由器命令管理。          缺點:需要手工指定,網路過大無法使用。
     動態路由:這種路由由網路路由協議根據拓撲或流量改變而自動調整。  缺點:容易佔用網路頻寬
     當路由器數量少的時候建議使用靜態路由,當路由器數量多的時候建議使用動態路由
     常見的動態路由協議包括RIP、OSPF、IS-IS、IGRP、EIGRP、BGP等。
二、RIP路由協議

RIP是Routing Information Protocol(路由資訊協議)的簡稱。它是一種較為簡單的內部閘道器協議IGP(Interior Gateway Protocol),主要用於規模較小的網路中,比如校園網以及結構較簡單的地區性網路。對於更為複雜的環境和大型網路,一般不使用RIP。 RIP是一種基於距離向量(Distance-Vector)演算法的協議,它通過UDP報文進行路由資訊的交換,使用的埠號為520。

RIP使用跳數(Hop Count)來衡量到達目的地址的距離,稱為度量值。在RIP中,預設情況下,路由器到與它直接相連網路的跳數為0,通過一個路由器可達的網路的跳數為1,其餘依此類推。也就是說,度量值等於從本網路到達目的網路間的路由器數量。為限制收斂時間,RIP規定度量值取0~15之間的整數,大於或等於16的跳數被定義為無窮大,即目的網路或主機不可達。由於這個限制,使得RIP不可能在大型網路中得到應用。

為提高效能,防止產生路由迴圈,RIP支援水平分割(Split Horizon)和毒性反轉(Poison Reverse)功能。由於RIP的實現較為簡單,在配置和維護管理方面也遠比OSPF和IS-IS容易,因此在實際組網中仍有廣泛的應用。                                                                                                                                                                                                                                                       RIP有兩個版本:RIP V1RIP V2

1、RIP V1是有類別路由協議(Classful Routing Protocol),它只支援以廣播方式釋出協議報文。RIP-1的協議報文中沒有攜帶掩碼資訊,它只能識別A、B、C類這樣的自然網段的路由,因此RIP-1無法支援路由聚合,也不支援不連續子網(Discontiguous Subnet)。

2、RIP V2是一種無分類路由協議(Classless Routing Protocol),與RIP-1相比,它有以下優勢:

  *支援外部路由標記(Route Tag),可以在路由策略中根據Tag對路由進行靈活的控制。

  *報文中攜帶掩碼資訊,支援路由聚合和CIDR(Classless Inter-Domain Routing)。

  *支援指定下一跳,在廣播網上可以選擇到最優下一跳地址。

  *支援使用組播方式傳送更新報文,只有RIP-2路由器才能收到協議報文,減少資源消耗。

  *支援對協議報文進行驗證,並提供明文驗證和MD5驗證兩種方式,增強安全性。                                                                                                                                     三、EIGRP路由協議                                    

EIGRP由於IGRP協議的種種缺陷以及不足,Cisco開發了EIGRP協議(增強型內部閘道器路由協議)來取代IGRP協議。EIGRP屬於高階距離向量路由協議(又稱混合型路由協議),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協議在Cisco裝置網路環境中廣泛部署。                                                               *參考資料: https://www.itread01.com/content/1548675725.html                                                                                                                              作業設定步驟:

1. PC1 tracert PC2
2. In Router 1,Router 2, Router3, Router4  
   刪除所有靜態路由
   no ip route xx.xx.xx.xx xx.xx.xx.xx xx.xx.xx.xx
   conf t
   router rip
   version 2
   network 211.81.xxx.0
   network 151.61.0.0
3. R1 s0/2復線
   conf t
   int s0/2
   no shutdown
4.等待一段時間並觀察路由表
PC1 tracert PC2
5. In Router 1,Router 2, Router3, Router4
   刪除所有RIPv2路由
   conf t
   no router rip
   router eigrp 100
   network 231.91.xxx.0
   network 161.81.0.0
6. R1 s0/0復線
   conf t
   int s0/0
   no  shutdown
7.等待一段時間並觀察路由表
   PC1 tracert PC2                                                                                                                                                                                                                                                                                                                                                                                             
*參考資料: https://ewell.com.tw/net/0615_2b5.mkv
心得:
上次上課教的是無連上網路的螢況下做靜態路由的IP Route設定,而這次作業是在做關於動態路由繞送的運作原理並建立動態(dynamic)路由表,模擬網路故障時,路由表變化情形並使用tracert驗證。雖然因為疫情停課再加上我們家的電腦無法做使用,因此只能暫時透過老師講解的影片學習。老師一步一步耐心的教,加上我有上網查看一些相關資料,才慢慢理解。以前總是覺得網路IP協定以及路由器很複雜,也沒什麼概念,但透過二下有這個機會上到這門課,雖然不是非常深入知道,但跟以前比也了解不少。                                    


       

            


1061B108103234 發表於 昨天 09:12 | 顯示全部樓層
[size=15.008px]RIP很早就被用在Internet上,是最簡單的路由協定。它是「路由資訊協定(Route Information Protocol)」的簡寫,主要傳遞路由資訊,通過每隔30秒廣播一次[size=15.008px]路由表[size=15.008px],維護相鄰路由器的位置關係,同時根據收到的路由表資訊計算自己的路由表資訊。RIP是一個[size=15.008px]距離向量路由協定[size=15.008px],最大跳數為15跳,超過15跳的網路則認為目標網路不可達。此協定通常用在網路架構較為簡單的小型網路環境。現在分為RIPv1和RIPv2兩個版本,後者支援[size=15.008px]VLSM[size=15.008px]技術以及一系列技術上的改進。RIP的收斂速度較慢。
[size=15.008px]IGRP協定是「內部網路關路由協定(Interior Gateway Routing Protocol)」的縮寫,由[size=15.008px]Cisco[size=15.008px]於二十世紀八十年代獨立開發,屬於Cisco私有協定。IGRP和RIP一樣,同屬距離向量路由協定,因此在諸多方面有著相似點,如IGRP也是周期性的廣播路由表,也存在最大跳數(預設為100跳,達到或超過100跳則認為目標網路不可達)。IGRP最大的特點是使用了混合度量值,同時考慮了鏈路的頻寬、延遲、負載、[size=15.008px]MTU[size=15.008px]、可靠性5個方面來計算路由的度量值,而不像其他IGP協定單純的考慮某一個方面來計算度量值。目前IGRP已經被Cisco獨立開發的EIGRP協定所取代,版本號為12.3及其以上的[size=15.008px]Cisco IOS[size=15.008px](Internetwork Operating System)已經不支援該協定,現在已經罕有執行IGRP協定的網路。
[size=15.008px]由於IGRP協定的種種缺陷以及不足,Cisco開發了EIGRP協定(增強型內部網路關路由協定)來取代IGRP協定。EIGRP屬於進階距離向量路由協定(又稱混合型路由協定),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協定在Cisco裝置網路環境中廣泛部署。
[size=15.008px]OSPF協定是「開放式最短路徑優先(Open Shortest Path First)」的縮寫,屬於鏈路狀態路由協定。OSPF提出了「區域(area)」的概念,每個區域中所有路由器維護著一個相同的鏈路狀態資料庫(LSDB)。區域又分為骨幹區域(骨幹區域的編號必須為0)和非骨幹區域(非0編號區域),如果一個執行OSPF的網路只存在單一區域,則該區域可以是骨幹區域或者非骨幹區域。如果該網路存在多個區域,那麼必須存在骨幹區域,並且所有非骨幹區域必須和骨幹區域直接相連。OSPF利用所維護的鏈路狀態資料庫,通過最短路徑優先演算法([size=15.008px]SPF[size=15.008px]演算法)計算得到路由表。OSPF的收斂速度較快。由於其特有的開放性以及良好的擴充性,目前OSPF協定在各種網路中廣泛部署。
[size=15.008px]心得:上次上課教的是無連上網路的螢況下做靜態路由的IP Route設定,而這次作業是在做關於動態路由繞送的運作原理並建立動態(dynamic)路由表,模擬網路故障時,路由表變化情形並使用tracert驗證。老師一步一步耐心的教,加上我有上網查看一些相關資料,才慢慢理解。以前總是覺得網路IP協定以及路由器很複雜,也沒什麼概念,但透過二下有這個機會上到這門課,雖然不是非常深入知道,但跟以前比也了解不少。
1061B108103206 發表於 昨天 09:19 | 顯示全部樓層

EIGRP路由協定的優點

EIGRP路由協定是由Cisco所開發出來的,與其他路由協定比較起來,最主要的不同就在於EIGRP路由協定的網路路徑收斂速度相當快,而所占用的網路頻寬也很小,因此EIGRP路由協定主要有以下這些特性:  

能夠最快完成網路路徑的收斂
當處於多變的網路環境時,EIGRP路由協定能夠在最短的時間內,完成網路路徑的收斂過程,甚至有些時候這樣的收斂過程幾乎是即時的,也就是說,一旦網路發生變化,EIGRP路由協定幾乎可以即時找到最新的最佳網路路徑。  

路由器在學習過程中對於任意兩個網路節點之間的路徑,有可能是一直改變的,因為會隨著學習而逐漸讓路由器明白怎樣的網路路徑是最好的,而到最後,一定會存在一個最佳的網路路徑,因此路由器在學習過程中從一開始學習到的路徑,一直到最終學習到最佳路徑的過程,就稱為網路路徑的「收斂」過程。這個收斂過程如果越快,代表路由器可以在最短的時間內學習到最佳的網路路徑。  

EIGRP路由協定所採用的演算法為Diffusing Update Algorithm,簡稱為DUAL。所以,EIGRP路由協定通常會把備用路徑儲存起來,以便不時之需,所以在須要使用這些備用路徑時就會很快。但也會發生另一種情況,在連備用路徑也不敷使用時,可能是因為某些原因讓本地端的備用資料庫內找不到這樣的路徑,此時路由器就會向鄰近的路由器求救,要求別的路由器告知是否有其他好的路徑可以到達想送達的目的地。  

占用較低的網路資源
路由器在學習的過程中,難免要與其他路由器作溝通,互相交換資訊以便學習網路路徑,這些交換的過程都會占據網路資源。而學習到最佳網路路徑時,各個路由器也必須維護這些路徑的資料,一樣會占據網路資源。不過,在一般正常的情況之下,EIGRP路由協定的網路資源占用率相當低,如果網路一切正常,也就是網路沒有經常改變,EIGRP路由協定只會傳送Hello封包。這些Hello封包是用來檢查鄰近的路由器設備是否還「存活」,所有的Link State路由協定都會使用這樣的機制來確保各個路由器之間的關係是正常運作的。而當鄰近的路由器設備接收到Hello封包後,會在自己的本地端建立一份Neighbor Table,以便記錄附近有哪些路由器設備。  

路由資料更新頻率低,更新資料筆數少
雖然IGRP路由協定會定期發送路由更新,但EIGRP路由協定並不會定期發送這樣的路由更新,只有當網路發生變化時,EIGRP路由協定才會發送路由更新,而且也不是更新整份Routing Table,只會更新有變動的部分,這樣的作法可以大幅地減少網路頻寬的使用量,以便降低網路資源的占用率。而且預設上,EIGRP路由協定會是Classful的路由協定,所以支援自動路由匯總(Automatic Route Summarization)。而其他Classful路由協定的手動路由匯總(Manual Route Summarization)則可以自行設定以避免Routing Table資料量過大,因此比較不一樣。  

支援多種網路協定
與其他路由協定不同的是,EIGRP路由協定支援多種網路協定,例如IP、IPX和AppleTalk等,這讓EIGRP路由協定有更大的擴展空間,也能夠支援各種不同的網路架構。  

具備高信賴度的路由資料
AD值是一個從0~255的整數,每一種路由協定都有一個AD值與其對應,代表這個路由協定所提供資訊的可靠程度,其值越低,代表可靠程度越高,用下面這個圖來舉例說明:  


假設Router A要轉送網路封包到Router D設備,在Router A的Routing Table中,有一筆路由顯示可以從Router B設備到達Router D,而這個路徑是採用靜態路由設定方式。另外,有一筆路由顯示能夠從Router C設備到達Router D設備,這條路由則是由RIP路由協定所學習而來。此時,Router A設備就會選擇靜態路由的方式,因為靜態路由的AD值比較低,代表靜態路由的可靠程度比較高。所有的動態路由協定的AD值與靜態路由的AD值如下表所示:  


從這個表格可以看出,EIGRP路由協定的AD值相當低,代表EIGRP路由協定的路由資料比其他的路由協定還要可靠,之前所提到的RIP路由協定和IGRP路由協定完全比不上。


1061B108103212 發表於 昨天 09:22 | 顯示全部樓層
動態路由協議-RIP

一、首先來看一下靜態路由協議個動態路由協議的區別:
靜態路由:這種路由由網路管理員手動輸入路由器命令管理。缺點:需要手工指定,網路過大無法使用。
動態路由:這種路由由網路路由協議根據拓撲或流量改變而自動調整。缺點:容易佔用網路頻寬。
當路由器數量少的時候建議使用靜態路由,當路由器數量多的時候建議使用動態路由。
二、路由協議分為兩種也叫做自治系統:
自治系統是通用管理域中的網路的集合
內部閘道器協議在自治系統中工作
外部閘道器協議連線不同的自治系統
1.內部閘道器路由協議:RIP\EIGRP\OSPF
而我們通常所說的AS就是指的一組或者一片由管理員來管理的路由器。(比如上圖中的左半個區域)
2.外部閘道器路由協議:BGP
三、內部動態路由協議的型別
1.距離向量 RIP、IGRP
2.高階距離向量EIGRP(cisco私有的)
3.鏈路狀態 OSPF IS.IS
距離向量:
“距離”表示有多遠,經過幾臺路由器,經過幾跳。
“向量”表示在哪個方向上,從哪個介面轉發出去。
距離向量路由協議會隔一定時間將路由表裡的所有路由傳給自己的鄰居。週期的。
四、RIP的工作原理:
1.首先路由器會先學習到自身所在的直連網段的路由資訊。
2.當執行RIP動態路由協議的時候,路由器會每隔30秒向鄰居(指的是直接相連的路由器)傳送路由表。
但是在傳送之前,會把路由資訊的Metric值+1之後傳給鄰居。
心得:這次的實驗很有趣,一開始看到RIP還以為是什麼不吉利的東西,但沒想到有他自己專業的用途,學到了新的知識很開心

1061B108103216 發表於 昨天 10:12 | 顯示全部樓層

EIGRP路由協定的優點

EIGRP路由協定是由Cisco所開發出來的,與其他路由協定比較起來,最主要的不同就在於EIGRP路由協定的網路路徑收斂速度相當快,而所占用的網路頻寬也很小,因此EIGRP路由協定主要有以下這些特性:  

能夠最快完成網路路徑的收斂
當處於多變的網路環境時,EIGRP路由協定能夠在最短的時間內,完成網路路徑的收斂過程,甚至有些時候這樣的收斂過程幾乎是即時的,也就是說,一旦網路發生變化,EIGRP路由協定幾乎可以即時找到最新的最佳網路路徑。  

路由器在學習過程中對於任意兩個網路節點之間的路徑,有可能是一直改變的,因為會隨著學習而逐漸讓路由器明白怎樣的網路路徑是最好的,而到最後,一定會存在一個最佳的網路路徑,因此路由器在學習過程中從一開始學習到的路徑,一直到最終學習到最佳路徑的過程,就稱為網路路徑的「收斂」過程。這個收斂過程如果越快,代表路由器可以在最短的時間內學習到最佳的網路路徑。  

EIGRP路由協定所採用的演算法為Diffusing Update Algorithm,簡稱為DUAL。所以,EIGRP路由協定通常會把備用路徑儲存起來,以便不時之需,所以在須要使用這些備用路徑時就會很快。但也會發生另一種情況,在連備用路徑也不敷使用時,可能是因為某些原因讓本地端的備用資料庫內找不到這樣的路徑,此時路由器就會向鄰近的路由器求救,要求別的路由器告知是否有其他好的路徑可以到達想送達的目的地。  

占用較低的網路資源
路由器在學習的過程中,難免要與其他路由器作溝通,互相交換資訊以便學習網路路徑,這些交換的過程都會占據網路資源。而學習到最佳網路路徑時,各個路由器也必須維護這些路徑的資料,一樣會占據網路資源。不過,在一般正常的情況之下,EIGRP路由協定的網路資源占用率相當低,如果網路一切正常,也就是網路沒有經常改變,EIGRP路由協定只會傳送Hello封包。這些Hello封包是用來檢查鄰近的路由器設備是否還「存活」,所有的Link State路由協定都會使用這樣的機制來確保各個路由器之間的關係是正常運作的。而當鄰近的路由器設備接收到Hello封包後,會在自己的本地端建立一份Neighbor Table,以便記錄附近有哪些路由器設備。  

路由資料更新頻率低,更新資料筆數少
雖然IGRP路由協定會定期發送路由更新,但EIGRP路由協定並不會定期發送這樣的路由更新,只有當網路發生變化時,EIGRP路由協定才會發送路由更新,而且也不是更新整份Routing Table,只會更新有變動的部分,這樣的作法可以大幅地減少網路頻寬的使用量,以便降低網路資源的占用率。而且預設上,EIGRP路由協定會是Classful的路由協定,所以支援自動路由匯總(Automatic Route Summarization)。而其他Classful路由協定的手動路由匯總(Manual Route Summarization)則可以自行設定以避免Routing Table資料量過大,因此比較不一樣。  

支援多種網路協定
與其他路由協定不同的是,EIGRP路由協定支援多種網路協定,例如IP、IPX和AppleTalk等,這讓EIGRP路由協定有更大的擴展空間,也能夠支援各種不同的網路架構。  

具備高信賴度的路由資料
AD值是一個從0~255的整數,每一種路由協定都有一個AD值與其對應,代表這個路由協定所提供資訊的可靠程度,其值越低,代表可靠程度越高,用下面這個圖來舉例說明:  


假設Router A要轉送網路封包到Router D設備,在Router A的Routing Table中,有一筆路由顯示可以從Router B設備到達Router D,而這個路徑是採用靜態路由設定方式。另外,有一筆路由顯示能夠從Router C設備到達Router D設備,這條路由則是由RIP路由協定所學習而來。此時,Router A設備就會選擇靜態路由的方式,因為靜態路由的AD值比較低,代表靜態路由的可靠程度比較高。所有的動態路由協定的AD值與靜態路由的AD值如下表所示:  


從這個表格可以看出,EIGRP路由協定的AD值相當低,代表EIGRP路由協定的路由資料比其他的路由協定還要可靠,之前所提到的RIP路由協定和IGRP路由協定完全比不上。




1061B108103211 發表於 昨天 11:04 | 顯示全部樓層

EIGRP(Enhanced Interior Gateway Routing Protocol ) 加強型內部閘道器路由協議
EIGRP路由協議特點:
1、 它是擴充套件計算,而不是單獨計算(即整個網路一起更新),路由器使用多播地址224.0.0.10通過EIGRP介面向外傳送hello分組,EIGRP路由從屬於同一個自治系統(AS)的其他路由器那裡收到hello分組後,將與該路由器建立鄰接關係。
2、 EIGRP所能支援的最大跳數是224跳,預設 100跳。
3、 它可為多種網路層協議提供路由支援
4、 EIGRP收斂佔頻寬的50%;內部管理距離(AD)為90,外部EIGRP路由AD為170
5、 預設EIGRP可以支援最多4條鏈路的不等代價的負載均衡
6、 EIGRP 是非週期的部分有邊界的更新 (即有新資訊時才更新,通過組播增量更新,有一個虛擬的DR,把更新傳送給虛擬的DR,由它負責擴散)
7、 維護著三張表鄰居表、拓撲表、路由表。支援IPV6、支援可變長子網掩碼、路由彙總
EIGRP配置:

  • Router(config)#router eigrp autonomous-system
    配置執行EIGRP路由協議,網路的自治系統號
  • Router(config-router)#network network-number
    宣告的網路為本路由自己直連的網路號
  • Router(config-router)# passive-interface E1/2
    在指定的介面上(E1/2)停止EIGRP的執行
  • EIGRP中釋出RIP
    Router(config)#router eigrp 10
    Router(config-router)#redistribute rip metric 100 100 100 1 1500
    (頻寬、延遲、可靠性、負載、最大傳輸單元)
  • RIP中釋出EIGRP
    Router(config)#router rip
    Router(config-router)# redistribute eigrp 10 metric 1
  • 在OSPF中釋出RIP、釋出直連
    Router(config-router)# redistribute rip metric 200 subnets
    Router(config-router)#redistribute connected subnets metric-type 1(可修改型別為1)
  • Router(config-router)#no auto-summary
    在EIGRP中關閉路由自動彙總
    8.幀中繼配置:
    封裝幀中繼
    encapsulation frame-relay { cisco | ietf } (預設為cisco型別)
    配置地址對映到DLCI
    frame-relay map ip 192.168.1.2 101 broadcast (對端IP地址,本機的DLCI號)
    show frame-relay rou檢視地址對映表
    no frame-relay inverse-arp關閉反向ARP
    Router(config)#frame-relay switching配置成幀中繼交換機
    frame-relay intf-type dce配置幀中繼交換機介面為DCE(此命令在幀中繼交換機上配置)
    frame-relay route 101 interface Serial1/2 102 (本介面--直連DLCI號--FR上的對點介面號—DLCI號。注:此命令在幀中繼交換機上配置)
  • 配置EIGRP認證
    r1(config)#key chain ccc //定義鑰匙鏈eigrp(名字任意取)
    r1(config-keychain)#key 1 //KEY ID為1
    r1(config-keychain-key)#key-string cisco //密碼為cisco
    r1(config-if)#ip authentication key-chain eigrp(協議) 1 (AS號)ccc (鑰匙鏈名字) //啟用EIGRP認證
    r1(config-if)#ip authentication mode eigrp 1 (AS號)md5 //認證模式MD5

1061B108103215 發表於 昨天 15:06 | 顯示全部樓層
RIP & EIGRP 動態路由
一、靜態路由與動態路由差別
     靜態路由:這種路由由網路管理員手動輸入路由器命令管理。          缺點:需要手工指定,網路過大無法使用。
     動態路由:這種路由由網路路由協議根據拓撲或流量改變而自動調整。  缺點:容易佔用網路頻寬
     當路由器數量少的時候建議使用靜態路由,當路由器數量多的時候建議使用動態路由
     常見的動態路由協議包括RIP、OSPF、IS-IS、IGRP、EIGRP、BGP等。
二、RIP路由協議

RIP是Routing Information Protocol(路由資訊協議)的簡稱。它是一種較為簡單的內部閘道器協議IGP(Interior Gateway Protocol),主要用於規模較小的網路中,比如校園網以及結構較簡單的地區性網路。對於更為複雜的環境和大型網路,一般不使用RIP。 RIP是一種基於距離向量(Distance-Vector)演算法的協議,它通過UDP報文進行路由資訊的交換,使用的埠號為520。

RIP使用跳數(Hop Count)來衡量到達目的地址的距離,稱為度量值。在RIP中,預設情況下,路由器到與它直接相連網路的跳數為0,通過一個路由器可達的網路的跳數為1,其餘依此類推。也就是說,度量值等於從本網路到達目的網路間的路由器數量。為限制收斂時間,RIP規定度量值取0~15之間的整數,大於或等於16的跳數被定義為無窮大,即目的網路或主機不可達。由於這個限制,使得RIP不可能在大型網路中得到應用。

為提高效能,防止產生路由迴圈,RIP支援水平分割(Split Horizon)和毒性反轉(Poison Reverse)功能。由於RIP的實現較為簡單,在配置和維護管理方面也遠比OSPF和IS-IS容易,因此在實際組網中仍有廣泛的應用。                                                                                                                                                                                                                                                       RIP有兩個版本:RIP V1RIP V2

1、RIP V1是有類別路由協議(Classful Routing Protocol),它只支援以廣播方式釋出協議報文。RIP-1的協議報文中沒有攜帶掩碼資訊,它只能識別A、B、C類這樣的自然網段的路由,因此RIP-1無法支援路由聚合,也不支援不連續子網(Discontiguous Subnet)。

2、RIP V2是一種無分類路由協議(Classless Routing Protocol),與RIP-1相比,它有以下優勢:

  *支援外部路由標記(Route Tag),可以在路由策略中根據Tag對路由進行靈活的控制。

  *報文中攜帶掩碼資訊,支援路由聚合和CIDR(Classless Inter-Domain Routing)。

  *支援指定下一跳,在廣播網上可以選擇到最優下一跳地址。

  *支援使用組播方式傳送更新報文,只有RIP-2路由器才能收到協議報文,減少資源消耗。

  *支援對協議報文進行驗證,並提供明文驗證和MD5驗證兩種方式,增強安全性。                                                                                                                                     三、EIGRP路由協議                                    

EIGRP由於IGRP協議的種種缺陷以及不足,Cisco開發了EIGRP協議(增強型內部閘道器路由協議)來取代IGRP協議。EIGRP屬於高階距離向量路由協議(又稱混合型路由協議),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協議在Cisco裝置網路環境中廣泛部署。                                                               *參考資料: https://www.itread01.com/content/1548675725.html                                                                                                                              作業設定步驟:

1. PC1 tracert PC2
2. In Router 1,Router 2, Router3, Router4  
   刪除所有靜態路由
   no ip route xx.xx.xx.xx xx.xx.xx.xx xx.xx.xx.xx
   conf t
   router rip
   version 2
   network 211.81.xxx.0
   network 151.61.0.0
3. R1 s0/2復線
   conf t
   int s0/2
   no shutdown
4.等待一段時間並觀察路由表
PC1 tracert PC2
5. In Router 1,Router 2, Router3, Router4
   刪除所有RIPv2路由
   conf t
   no router rip
   router eigrp 100
   network 231.91.xxx.0
   network 161.81.0.0
6. R1 s0/0復線
   conf t
   int s0/0
   no  shutdown
7.等待一段時間並觀察路由表
   PC1 tracert PC2                                                                                                                                                                                                                                                                                                                                                                                             
*參考資料: https://ewell.com.tw/net/0615_2b5.mkv
心得:這次作業是在做關於動態路由繞送的運作原理並建立動態路由表,模擬網路故障時,路由表變化情形並使用tracert驗證,雖然家裡的電腦無法使用,但我都有認真聽老師的講解學習,也有上網查相關資料,即使無法跟大部分同學一樣實作,但我覺得自己還是學到了很多東西,讓我在網路IP協定以及路由器上更有概念
1061B108103250 發表於 昨天 16:06 | 顯示全部樓層
本帖最後由 1061B108103250 於 2021-6-22 16:11 編輯

路由協定[size=15.008px](英語:[size=15.008px]Routing protocol[size=15.008px])是一種指定[size=15.008px]封包[size=15.008px]轉送方式的網路協定。[size=15.008px]Internet[size=15.008px]網路的主要節點裝置是[size=15.008px]路由器[size=15.008px],路由器通過[size=15.008px]路由表[size=15.008px]來轉發接收到的資料。轉發策略可以是人工指定的(通過[size=15.008px]靜態路由[size=15.008px]、[size=15.008px]策略路由[size=15.008px]等方法)。在具有較小規模的網路中,人工指定轉發策略沒有任何問題。但是在具有較大規模的網路中(如跨國企業網路、[size=15.008px]ISP[size=15.008px]網路),如果通過人工指定轉發策略,將會給網路管理員帶來巨大的工作量,並且在管理、維護路由表上也變得十分困難。為了解決這個問題,動態路由協定應運而生。動態路由協定可以讓路由器自動學習到其他路由器的網路,並且網路拓撲發生改變後自動更新路由表。網路管理員只需要組態動態路由協定即可,相比人工指定轉發策略,工作量大大減少。
RIP
RIP很早就被用在Internet上,是最簡單的路由協定。它是「路由資訊協定(Route Information Protocol)」的簡寫,主要傳遞路由資訊,通過每隔30秒廣播一次[size=15.008px]路由表,維護相鄰路由器的位置關係,同時根據收到的路由表資訊計算自己的路由表資訊。RIP是一個[size=15.008px]距離向量路由協定,最大跳數為15跳,超過15跳的網路則認為目標網路不可達。此協定通常用在網路架構較為簡單的小型網路環境。現在分為RIPv1和RIPv2兩個版本,後者支援[size=15.008px]VLSM技術以及一系列技術上的改進。RIP的收斂速度較慢。
EIGRP由於IGRP協定的種種缺陷以及不足,Cisco開發了EIGRP協定(增強型內部網路關路由協定)來取代IGRP協定。EIGRP屬於進階距離向量路由協定(又稱混合型路由協定),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協定在Cisco裝置網路環境中廣泛部署。
一、靜態路由與動態路由差別
     靜態路由:這種路由由網路管理員手動輸入路由器命令管理。         
     動態路由:這種路由由網路路由協議根據拓撲或流量改變而自動調整。  
     當路由器數量少的時候建議使用靜態路由,當路由器數量多的時候建議使用動態路由
     常見的動態路由協議包括RIP、OSPF、IS-IS、IGRP、EIGRP、BGP等。
二、RIP路由協議

RIP是Routing Information Protocol(路由資訊協議)的簡稱。它是一種較為簡單的內部閘道器協議IGP(Interior Gateway Protocol),主要用於規模較小的網路中,比如校園網以及結構較簡單的地區性網路。對於更為複雜的環境和大型網路,一般不使用RIP。 RIP是一種基於距離向量(Distance-Vector)演算法的協議,它通過UDP報文進行路由資訊的交換,使用的埠號為520。

RIP使用跳數(Hop Count)來衡量到達目的地址的距離,稱為度量值。在RIP中,預設情況下,路由器到與它直接相連網路的跳數為0,通過一個路由器可達的網路的跳數為1,其餘依此類推。也就是說,度量值等於從本網路到達目的網路間的路由器數量。為限制收斂時間,RIP規定度量值取0~15之間的整數,大於或等於16的跳數被定義為無窮大,即目的網路或主機不可達。由於這個限制,使得RIP不可能在大型網路中得到應用。

為提高效能,防止產生路由迴圈,RIP支援水平分割(Split Horizon)和毒性反轉(Poison Reverse)功能。由於RIP的實現較為簡單,在配置和維護管理方面也遠比OSPF和IS-IS容易,因此在實際組網中仍有廣泛的應用。                                                                                                                                                                                                                                                       RIP有兩個版本:RIP V1RIP V2

1、RIP V1是有類別路由協議(Classful Routing Protocol),它只支援以廣播方式釋出協議報文。RIP-1的協議報文中沒有攜帶掩碼資訊,它只能識別A、B、C類這樣的自然網段的路由,因此RIP-1無法支援路由聚合,也不支援不連續子網(Discontiguous Subnet)。

2、RIP V2是一種無分類路由協議(Classless Routing Protocol),與RIP-1相比,它有以下優勢:

  *支援外部路由標記(Route Tag),可以在路由策略中根據Tag對路由進行靈活的控制。

  *報文中攜帶掩碼資訊,支援路由聚合和CIDR(Classless Inter-Domain Routing)。

  *支援指定下一跳,在廣播網上可以選擇到最優下一跳地址。

  *支援使用組播方式傳送更新報文,只有RIP-2路由器才能收到協議報文,減少資源消耗。



1061B108103202 發表於 昨天 16:17 | 顯示全部樓層

EIGRP(Enhanced Interior Gateway Routing Protocol ) 加強型內部閘道器路由協議
EIGRP路由協議特點:
1、 它是擴充套件計算,而不是單獨計算(即整個網路一起更新),路由器使用多播地址224.0.0.10通過EIGRP介面向外傳送hello分組,EIGRP路由從屬於同一個自治系統(AS)的其他路由器那裡收到hello分組後,將與該路由器建立鄰接關係。
2、 EIGRP所能支援的最大跳數是224跳,預設 100跳。
3、 它可為多種網路層協議提供路由支援
4、 EIGRP收斂佔頻寬的50%;內部管理距離(AD)為90,外部EIGRP路由AD為170
5、 預設EIGRP可以支援最多4條鏈路的不等代價的負載均衡
6、 EIGRP 是非週期的部分有邊界的更新 (即有新資訊時才更新,通過組播增量更新,有一個虛擬的DR,把更新傳送給虛擬的DR,由它負責擴散)
7、 維護著三張表鄰居表、拓撲表、路由表。支援IPV6、支援可變長子網掩碼、路由彙總
EIGRP配置:

  • Router(config)#router eigrp autonomous-system
    配置執行EIGRP路由協議,網路的自治系統號
  • Router(config-router)#network network-number
    宣告的網路為本路由自己直連的網路號
  • Router(config-router)# passive-interface E1/2
    在指定的介面上(E1/2)停止EIGRP的執行
  • EIGRP中釋出RIP
    Router(config)#router eigrp 10
    Router(config-router)#redistribute rip metric 100 100 100 1 1500
    (頻寬、延遲、可靠性、負載、最大傳輸單元)
  • RIP中釋出EIGRP
    Router(config)#router rip
    Router(config-router)# redistribute eigrp 10 metric 1
  • 在OSPF中釋出RIP、釋出直連
    Router(config-router)# redistribute rip metric 200 subnets
    Router(config-router)#redistribute connected subnets metric-type 1(可修改型別為1)
  • Router(config-router)#no auto-summary
    在EIGRP中關閉路由自動彙總
    8.幀中繼配置:
    封裝幀中繼
    encapsulation frame-relay { cisco | ietf } (預設為cisco型別)
    配置地址對映到DLCI
    frame-relay map ip 192.168.1.2 101 broadcast (對端IP地址,本機的DLCI號)
    show frame-relay rou檢視地址對映表
    no frame-relay inverse-arp關閉反向ARP
    Router(config)#frame-relay switching配置成幀中繼交換機
    frame-relay intf-type dce配置幀中繼交換機介面為DCE(此命令在幀中繼交換機上配置)
    frame-relay route 101 interface Serial1/2 102 (本介面--直連DLCI號--FR上的對點介面號—DLCI號。注:此命令在幀中繼交換機上配置)
  • 配置EIGRP認證
    r1(config)#key chain ccc //定義鑰匙鏈eigrp(名字任意取)
    r1(config-keychain)#key 1 //KEY ID為1
    r1(config-keychain-key)#key-string cisco //密碼為cisco
    r1(config-if)#ip authentication key-chain eigrp(協議) 1 (AS號)ccc (鑰匙鏈名字) //啟用EIGRP認證
    r1(config-if)#ip authentication mode eigrp 1 (AS號)md5 //認證模式MD5


1061B108103228 發表於 昨天 19:54 | 顯示全部樓層
EIGRP(Enhanced Interior Gateway Routing Protocol ) 加強型內部閘道器路由協議
EIGRP路由協議特點:
1、 它是擴充套件計算,而不是單獨計算(即整個網路一起更新),路由器使用多播地址224.0.0.10通過EIGRP介面向外傳送hello分組,EIGRP路由從屬於同一個自治系統(AS)的其他路由器那裡收到hello分組後,將與該路由器建立鄰接關係。
2、 EIGRP所能支援的最大跳數是224跳,預設 100跳。
3、 它可為多種網路層協議提供路由支援
4、 EIGRP收斂佔頻寬的50%;內部管理距離(AD)為90,外部EIGRP路由AD為170
5、 預設EIGRP可以支援最多4條鏈路的不等代價的負載均衡
6、 EIGRP 是非週期的部分有邊界的更新 (即有新資訊時才更新,通過組播增量更新,有一個虛擬的DR,把更新傳送給虛擬的DR,由它負責擴散)
7、 維護著三張表鄰居表、拓撲表、路由表。支援IPV6、支援可變長子網掩碼、路由彙總
EIGRP配置:

Router(config)#router eigrp autonomous-system
配置執行EIGRP路由協議,網路的自治系統號
Router(config-router)#network network-number
宣告的網路為本路由自己直連的網路號
Router(config-router)# passive-interface E1/2
在指定的介面上(E1/2)停止EIGRP的執行
EIGRP中釋出RIP
Router(config)#router eigrp 10
Router(config-router)#redistribute rip metric 100 100 100 1 1500
(頻寬、延遲、可靠性、負載、最大傳輸單元)
RIP中釋出EIGRP
Router(config)#router rip
Router(config-router)# redistribute eigrp 10 metric 1
在OSPF中釋出RIP、釋出直連
Router(config-router)# redistribute rip metric 200 subnets
Router(config-router)#redistribute connected subnets metric-type 1(可修改型別為1)
Router(config-router)#no auto-summary
在EIGRP中關閉路由自動彙總
8.幀中繼配置:
封裝幀中繼
encapsulation frame-relay { cisco | ietf } (預設為cisco型別)
配置地址對映到DLCI
frame-relay map ip 192.168.1.2 101 broadcast (對端IP地址,本機的DLCI號)
show frame-relay rou檢視地址對映表
no frame-relay inverse-arp關閉反向ARP
Router(config)#frame-relay switching配置成幀中繼交換機
frame-relay intf-type dce配置幀中繼交換機介面為DCE(此命令在幀中繼交換機上配置)
frame-relay route 101 interface Serial1/2 102 (本介面--直連DLCI號--FR上的對點介面號—DLCI號。注:此命令在幀中繼交換機上配置)
配置EIGRP認證
r1(config)#key chain ccc //定義鑰匙鏈eigrp(名字任意取)
r1(config-keychain)#key 1 //KEY ID為1
r1(config-keychain-key)#key-string cisco //密碼為cisco
r1(config-if)#ip authentication key-chain eigrp(協議) 1 (AS號)ccc (鑰匙鏈名字) //啟用EIGRP認證
r1(config-if)#ip authentication mode eigrp 1 (AS號)md5 //認證模式MD5
1061B108103223 發表於 昨天 20:09 | 顯示全部樓層
路由協定(英語:Routing protocol)是一種指定封包轉送方式的網路協定。Internet網路的主要節點裝置是路由器,路由器通過路由表來轉發接收到的資料。轉發策略可以是人工指定的(通過靜態路由策略路由等方法)。在具有較小規模的網路中,人工指定轉發策略沒有任何問題。但是在具有較大規模的網路中(如跨國企業網路、ISP網路),如果通過人工指定轉發策略,將會給網路管理員帶來巨大的工作量,並且在管理、維護路由表上也變得十分困難。為了解決這個問題,動態路由協定應運而生。動態路由協定可以讓路由器自動學習到其他路由器的網路,並且網路拓撲發生改變後自動更新路由表。網路管理員只需要組態動態路由協定即可,相比人工指定轉發策略,工作量大大減少。
RIP
RIP很早就被用在Internet上,是最簡單的路由協定。它是「路由資訊協定(Route Information Protocol)」的簡寫,主要傳遞路由資訊,通過每隔30秒廣播一次路由表,維護相鄰路由器的位置關係,同時根據收到的路由表資訊計算自己的路由表資訊。RIP是一個距離向量路由協定,最大跳數為15跳,超過15跳的網路則認為目標網路不可達。此協定通常用在網路架構較為簡單的小型網路環境。現在分為RIPv1和RIPv2兩個版本,後者支援VLSM技術以及一系列技術上的改進。RIP的收斂速度較慢。
EIGRP
由於IGRP協定的種種缺陷以及不足,Cisco開發了EIGRP協定(增強型內部網路關路由協定)來取代IGRP協定。EIGRP屬於進階距離向量路由協定(又稱混合型路由協定),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協定在Cisco裝置網路環境中廣泛部署。
網址:https://zh.wikipedia.org/wiki/%E8%B7%AF%E7%94%B1%E5%8D%8F%E8%AE%AE
心得:
上次上課教的是無連上網路的螢況下做靜態路由的IP Route設定,而這次作業是在做關於動態路由繞送的運作原理並建立動態(dynamic)路由表,模擬網路故障時,路由表變化情形並使用tracert驗證。雖然因為疫情停課再加上我們家的電腦無法做使用,因此只能暫時透過老師講解的影片學習。老師一步一步耐心的教,加上我有上網查看一些相關資料,才慢慢理解。

1061B108103238 發表於 11 小時前 | 顯示全部樓層
EIGRP(Enhanced Interior Gateway Routing Protocol ) 加強型內部閘道器路由協議
EIGRP特點:

1. 它可為多種網路層協議提供路由支援


2. EIGRP所能支援的最大跳數是224跳,預設 100跳。


3. 預設EIGRP可以支援最多4條鏈路的不等代價的負載均衡


4. EIGRP收斂佔頻寬的50%;內部管理距離(AD)為90,外部EIGRP路由AD為170


5. 維護著三張表鄰居表、拓撲表、路由表。支援IPV6、支援可變長子網掩碼、路由彙總


6. EIGRP 是非週期的部分有邊界的更新 (即有新資訊時才更新,通過組播增量更新,有一個虛擬的DR,把更新傳送給虛擬的DR,由它負責擴散)


7. 擴充套件計算,而非單獨計算,路由器使用多播地址224.0.0.10通過EIGRP介面向外傳送hello分組,EIGRP路由從屬於同一個自治系統的其他路由器那裡收到hello分組後,將與該路由器建立鄰接關係。

1061B108103242 發表於 6 小時前 | 顯示全部樓層
RIP & EIGRP 動態路由
一、靜態路由與動態路由差別
     靜態路由:這種路由由網路管理員手動輸入路由器命令管理。          缺點:需要手工指定,網路過大無法使用。
     動態路由:這種路由由網路路由協議根據拓撲或流量改變而自動調整。  缺點:容易佔用網路頻寬
     當路由器數量少的時候建議使用靜態路由,當路由器數量多的時候建議使用動態路由
     常見的動態路由協議包括RIP、OSPF、IS-IS、IGRP、EIGRP、BGP等。
二、RIP路由協議

RIP是Routing Information Protocol(路由資訊協議)的簡稱。它是一種較為簡單的內部閘道器協議IGP(Interior Gateway Protocol),主要用於規模較小的網路中,比如校園網以及結構較簡單的地區性網路。對於更為複雜的環境和大型網路,一般不使用RIP。 RIP是一種基於距離向量(Distance-Vector)演算法的協議,它通過UDP報文進行路由資訊的交換,使用的埠號為520。

RIP使用跳數(Hop Count)來衡量到達目的地址的距離,稱為度量值。在RIP中,預設情況下,路由器到與它直接相連網路的跳數為0,通過一個路由器可達的網路的跳數為1,其餘依此類推。也就是說,度量值等於從本網路到達目的網路間的路由器數量。為限制收斂時間,RIP規定度量值取0~15之間的整數,大於或等於16的跳數被定義為無窮大,即目的網路或主機不可達。由於這個限制,使得RIP不可能在大型網路中得到應用。

為提高效能,防止產生路由迴圈,RIP支援水平分割(Split Horizon)和毒性反轉(Poison Reverse)功能。由於RIP的實現較為簡單,在配置和維護管理方面也遠比OSPF和IS-IS容易,因此在實際組網中仍有廣泛的應用。                                                                                                                                                                                                                                                       RIP有兩個版本:RIP V1RIP V2

1、RIP V1是有類別路由協議(Classful Routing Protocol),它只支援以廣播方式釋出協議報文。RIP-1的協議報文中沒有攜帶掩碼資訊,它只能識別A、B、C類這樣的自然網段的路由,因此RIP-1無法支援路由聚合,也不支援不連續子網(Discontiguous Subnet)。

2、RIP V2是一種無分類路由協議(Classless Routing Protocol),與RIP-1相比,它有以下優勢:

  *支援外部路由標記(Route Tag),可以在路由策略中根據Tag對路由進行靈活的控制。

  *報文中攜帶掩碼資訊,支援路由聚合和CIDR(Classless Inter-Domain Routing)。

  *支援指定下一跳,在廣播網上可以選擇到最優下一跳地址。

  *支援使用組播方式傳送更新報文,只有RIP-2路由器才能收到協議報文,減少資源消耗。

  *支援對協議報文進行驗證,並提供明文驗證和MD5驗證兩種方式,增強安全性。                                                                                                                                     三、EIGRP路由協議                                    

EIGRP由於IGRP協議的種種缺陷以及不足,Cisco開發了EIGRP協議(增強型內部閘道器路由協議)來取代IGRP協議。EIGRP屬於高階距離向量路由協議(又稱混合型路由協議),繼承了IGRP的混合度量值,最大特點在於引入了非等價負載均衡技術,並擁有極快的收斂速度。EIGRP協議在Cisco裝置網路環境中廣泛部署。                                                               *參考資料: https://www.itread01.com/content/1548675725.html                                                                                                                              作業設定步驟:

1. PC1 tracert PC2
2. In Router 1,Router 2, Router3, Router4  
   刪除所有靜態路由
   no ip route xx.xx.xx.xx xx.xx.xx.xx xx.xx.xx.xx
   conf t
   router rip
   version 2
   network 211.81.xxx.0
   network 151.61.0.0
3. R1 s0/2復線
   conf t
   int s0/2
   no shutdown
4.等待一段時間並觀察路由表
PC1 tracert PC2
5. In Router 1,Router 2, Router3, Router4
   刪除所有RIPv2路由
   conf t
   no router rip
   router eigrp 100
   network 231.91.xxx.0
   network 161.81.0.0
6. R1 s0/0復線
   conf t
   int s0/0
   no  shutdown
7.等待一段時間並觀察路由表
   PC1 tracert PC2                                                                                                                                                                                                                                                                                                                                                                                             
*參考資料: https://ewell.com.tw/net/0615_2b5.mkv
心得:這次作業是關於動態路由繞送的運作原理並建立動態路由表,模擬網路故障時,路由表變化情形並使用tracert驗證,看到期間的變化我覺得非常新奇,沒想到網路能夠有這麼多的變化,讓我又更了解網路的一部分。
您需要登錄後才可以回帖 登錄 | 註冊

本版積分規則

小黑屋|手机版|Archiver|施勢帆老師的教學網站  

GMT+8, 2021-6-23 16:18 , Processed in 0.105696 second(s), 14 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回復 返回頂部 返回列表